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Welcome to StockXloader—getting quotes from any stock market

1 GETTING STARTED

1.1 Introduction
Everything you need to know in your daily use of StockXloader is provided by
the application, through menus or help buttons. All documentation, including
this User Guide, is available from the menus, so there is no need to copy any
documents anywhere. Any guidance are accessed via the following entries in the
Help, Tools and Application menus:

1. User Guide: The guide you are currently reading.

2. Read Me: Contains system requirements,
installation instructions, etcetera.

3. Release Notes: What’s new in this version, version
history, any known “issues” (problems).

4. Troubleshooting: Procedures for isolating the source of
a problem you may experience.

5. Online FAQ: “Frequently Asked Questions”.

6. Ticker-List Guide: How to write a ticker list.

7. License...: How to purchase a License Key for 
StockXloader.

8. License Agreement: The License Agreement for using
StockXloader in either Evaluation
or Licensed mode.

9. Product Page: The web page for StockXloader.

1.2 Highlights of StockXloader:

◆ StockXloader is a native Mac OS X application for fully automated down-
loading of stock market quotes and indexes to the technical analysis 
program ProTA or ProTA Gold from BeeSoft (http://beesoft.net) — effectively 
building an arbitrarily large database of tickers containing historical quotes 
for the open/high/low/close of each day!

◆ It collects quotes from Yahoo! Finance for any stock exchange in the world 
that Yahoo! Finance carry quotes for.

◆ The downloaded information is then imported into the ProTA database. In 
the process, it informs ProTA which tickers are stocks, which are mutual 
funds, and which are indexes, options or futures, so that any new ticker is 
placed into the right category by ProTA with the full name of the security.
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1.3 Basic Usage

The StockXloader panel and menu items provide what you need to know in
your daily usage, and StockXloader will report any anomalies in a “drawer”
below the panel. Before you start downloading for the first time, however, read
this section and Chapter 6 to get a smooth start without problems or unexpected
surprises.

◆ The first time you start StockXloader, you are prompted to set the Last Date 
of downloads according to a choice of: 1 day, week, month, year, 5 or 10 
years. That is just a starting point—you can easily change the date for the 
individual ticker lists later.

◆ Enter Yahoo tickers of your choice (with or without their full security names 
and types) in one or all of the four ticker lists accessed from the Tools 
menu: Tools > Yahoo Tickers (EU), or Yahoo Tickers (US), or Yahoo Tickers (A), or 
Yahoo Tickers (X). Each list is a separate plain-text file.

The guide Tools > Ticker-List Guide shows you examples and rules.

The three lists, (EU), (US) and (A), could be thought of as three regions in 
the world. What EU and US stand for is obvious, but A can be thought of 
as suitable for, or matching any of the following: Asia, Australia, Africa, 
Americas, Argentina, Austria, Amsterdam, Auckland, Abroad, Auxiliary, A-
list, All, Alternate, Active, Abridged, Abbreviated, Addendum, Augmented, 
Assorted, Autonomous, just to name some examples.

The (X) list is primarily meant as a temporary “extra” list for getting quotes 
for some individual security you may be interested in. It makes it easy to 
“catch up” on a single security or a few securities without having to modify 
any of the other lists.

To find the right ticker symbol for a certain security (share/stock, fund, 
index, future, option, currency) choose Tools > Yahoo Web Locations > Ticker Symbol 
Lookup, or the shortcut equivalent Cmd-9, and then search for the security you 
are interested in.

◆ Basic use is of course to just push the Download button after having 
enabled/disabled (and possibly also reordered) sources according to your 
needs and according to the current time of day. Alternatively, choose the 
menu item Tools > Download, or the shortcut equivalent Cmd-D.
• For YahooCurrent, it will get the current intraday quotes, so to really get the 

true end-of-day figures, it is important that you wait until at least 15-30 
minutes after the stock exchange for the requested tickers has closed! Check 
the Yahoo site for the latest information on the delay for the different stock 
exchanges: http://finance.yahoo.com/exchanges.

• For YahooHistorical, the quotes make it into the databases some time after 
the exchanges have closed, usually during the night. The exact time is not 
specified, and it varies, but in practice, the quotes usually lag about one day 
if you download in the evening after the exchange has closed.

To get the current quotes of today, you may want to enable YahooCurrent 
in addition to YahooHistorical.

◆ If you have a check mark for a YahooCurrent source (i.e for today), then, 
after a download, it will display the current date in the Last Date column for 
that row, but it will not set the Last Date for the corresponding Yahoo-
Historical source! Therefore, next time you download historical data, it will 
download data also for that day, even if you might already have data for it. 
This way, you are ensured not to miss any data, since it is common that the 
data for the current day does not include all fields (open/high/low/close/
volume), whereas the historical data might include that. Also, if the 
exchange was not closed when you downloaded current day data, you will 
want to have the real end-of-day quotes later. It is therefore recommended 
that you set ProTA so that new data overwrites data for existing dates.

http://finance.yahoo.com/exchanges
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◆ Why would you want to reorder sources? Essentially, the reason is that the 
order of downloads affects quote priority—later values may or may not 
overwrite earlier values if you have the same ticker in more than one ticker 
list.
• The current version (3.2) of ProTA for OS X can be set to either skip existing 

dates or overwrite (replace) data for existing dates (In ProTA: Tools > Universal 
Text Importer, click Settings Database).

• If a future version of ProTA for OS X makes it possible to control Skip/
Replace/Fill-In via a script, StockXloader might be updated so that it can 
communicate the appropriate setting to ProTA according to a choice in the 
main panel.

◆ The Download button will intentionally be grayed-out when you enable/
disable or reorder the sources or change the Last Date. Press the Save or 
Revert button when you are ready, whereupon the Download button will 
be enabled again. Similarly, during download or after drag-and-drop of 
files, it will also be grayed-out until the process has finished.

◆ Your ProTA may be set in any date format you like—no need to use the US 
date format! Also, you may have ProTA set with decimal comma instead of 
decimal point if you like.

◆ After StockXloader has finished downloading, it will launch ProTA and 
show its Universal Importer for a file called Import2ProTA. At this stage, 
you can choose whether ProTA should create new symbols automatically or 
not, and whether to skip or replace data for existing dates, and if you need 
to map tickers to new names. You can set up ProTA so that it automatically 
makes those settings each time you import from StockXloader; read more 
about that feature in Chapter 6 of this guide. With the proper settings, all 
you need to do at this stage is to click the button Start Import.

◆ After you have imported into ProTA, you may want to do Tools > Notes from 
the StockXloader menu, which will open a text document, where you can 
enter various notes, such as new or missing tickers, renaming or merges, 
changes etcetera. Other notes of relevance to enter in that file are informa-
tion about various corrections you have done to the database.

1.4 Drag-and-drop Usage
You can also drag files to the Download button; these files may either be those
that StockXloader have already downloaded for you, or they may be files you
have manually downloaded to complement some missing dates. They must
exactly match the following specification:

They must be Yahoo historical quotes. They must have either US spread-
sheet dates with either 2- or 4-digit year, or they may have ISO dates (yyyy-
mm-dd). (You will automatically get one of these when you download data 
in spreadsheet format—even when you browse from a “national” Yahoo 
version), and each file name must contain: “(ticker)” where ticker is any 
sequence of characters enclosed by the parentheses, but preferably the 
actual Yahoo ticker.
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2 STOCKXLOADER FEATURES

◆ The system treats current quotes and historical daily quotes of securities 
such as stocks, mutual funds and indexes. For a list of Yahoo tickers, you 
can:
(1) download all current quotes, even for hundreds of tickers!

(2) download historical quotes for all those tickers for many years back in time! 
(Provided Yahoo has the data.)

◆ StockXloader keeps four separate “region” lists, which you can fill with 
“arbitrarily” many tickers (hundreds, preferably not thousands) from almost 
any stock exchange in the world. They are simple plain-text files that can 
be edited with any editor for plain text. The reasons there are four lists are: 
• Due to time zone differences, you will want to differentiate your downloads, 

so you can make sure that the exchange has closed when you download the 
quotes for today.

• While only one or two regions in the world might be your trading interest, 
it is extremely convenient to have extra lists for temporary usage, such as 
when picking up a new ticker for which you want to download a few years 
of data.

◆ For each ticker list, StockXloader keeps track of the last date you success-
fully downloaded historical data (really got some data, not just attempted a 
download!). All this information is kept visually updated in a live table so 
you immediately know the status.

◆ For all dates of last download, you can back any of them as much as you 
need—days, months, years—for building a historical database! Just click a 
row and then change the date by clicking date steppers above the table.

◆ StockXloader provides you with very detailed progress information con-
cerning how the download and conversion proceeds. In addition, it pro-
vides a Message Log drawer that gradually fills up with various information 
as to how much has been downloaded, what is currently being processed, 
missing dates, empty tickers, error conditions etcetera.

◆ For Yahoo historical quotes, StockXloader warns you about those tickers 
that do not have any data or that do not have as recent quotes as the most 
recent ticker has—that protects you from being mislead, so that you can 
choose to set the date back and download again at a later time when the 
Yahoo databases have been updated. This way, you minimize the risk of 
getting “holes” in your own quote database.

◆ After all the files have been downloaded, they are processed to fit the 
import specifications for ProTA and the character set used in Mac OS X. The 
resulting information is assembled into a single file, and ProTA is launched 
and told to import this into its database. The processing of each file 
includes: 
• pattern matchings to search and verify fields, and to find out what the latest 

date is that really had some data;

• date interpretations and conversions, using 4-digit years in a format that is 
independent of your preferred date format in ProTA;

• creating the appropriate columns from file content and file name;

• optionally strips the stock exchange suffix from the Yahoo tickers;

• insertion of the full security names, obtained from the ticker lists, into a 
column of the file to import into ProTA so that when ProTA shall create new 
symbols, it will automatically get the full security names—this way, you 
automatically get the proper names into the database without having to 
enter each name in a dialog; the full security names may even contain such 
characters as “å, ä, ö, ü, é, è, ç”;

• insertion of special type codes that inform ProTA which tickers are stocks, 
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which are mutual funds, and which are indexes, options or futures, so that 
any new ticker is created in the right category by ProTA, and on subsequent 
downloads, the ticker category is automatically identified so that it knows 
which ticker to update;

• insertion of special control lines at the beginning of the file to import—
which instructs ProTA to use the correct column settings, delimiter and 
number format, plus it specifies a named settings format that e.g can asso-
ciate a named ticker mappings file (read more about that feature in 
Chapter 6).

◆ Help buttons are provided that guide you right where you might need the 
guidance, and throughout the application there is an extensive set of error 
handling functionality for a range of conceivable cases.

◆ StockXloader is extremely fast since it exploits many highly efficient Unix 
routines at the core of Mac OS X, while at the same time exploiting the best 
of the Mac OS X for its graphical user interface.

3 LICENSE KEY

Extended evaluation period If the trial period has expired, but you really need more evaluation time, e.g due
to a long “inactive” period, you can apply for an extended evaluation time. The
procedure for requesting such an extension is provided when you start
StockXloader and the trial period has expired or there are only three more days
left. You must provide at least some form of motivation, although we are pretty
liberal and generous about extensions.

Second license key A license key is valid for one user, identified with either the login Short Name,
which is the same as the name of the home folder, or with the full user name as
shown in System Preferences > Accounts. If you buy a new computer, or use more than
one computer, you will normally use the same account name and identifier. In
special rare cases, however, you may have elected to use different such names
on the different computers, despite you are the only user of StockXloader. If you
really need to get a second license key, BragIt may offer you that if you send a
mail to support@bragit.com and provide:

*   My full name = …
*   My current license key = …
*   The licensed User Name for the current key = … . . . . . . . . . . . . . . . . . (these are case sensitive)
*   The User Name (either 'Short Name' or full name) for the new requested key = …
*   My motivation for getting an additional license key = ...

Note that the User Name (both the 'Short Name' and the full name) are case
sensitive—Joe is not the same as joe. Naturally, BragIt can not grant you a new
license key automatically—only if the statement of reasons is motive enough.
Different people using StockXloader should buy their own license keys, unless
you accept that they all use the same login account on your computer and they
all work on the same database.
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4 GENERAL NOTES

Dates All dates presented by StockXloader in numerical form adhere to the Interna-
tional Standard ISO 8601, which stipulates: YYYY-MM-DD, where Y, M and D are
digits for year, month and day respectively.

Message log You can save the Message Log to a plain-text file if you want (use the File menu
Save...). The name of the file is automatically set to a name that includes the
current date, as in the following example: StockXloader log [2006-05-04].txt.

In the Message Log, certain warnings are highlighted in red. These warnings are
not necessarily fatal, but worth reading. An example being old data for some
tickers because new data has not yet arrived to the Yahoo databases; if only
some tickers have received new quotes, whereas others are not yet updated,
then, unless YahooCurrent provides the data, you should set the date back so
that you really get the complete data for all tickers the next time you download.
But if you are downloading old data, there might simply be no data for that
ticker in that time period.

Location of StockXloader files The menu item Tools > StockXloader Files will take you to
<your home>:Library:Application Support:StockXloader:
That’s where StockXloader stores the ticker files (the ticker lists). Temporary files
are downloaded into a subfolder there, along with the finally converted and
assembled file to be imported into ProTA: Import2ProTA.

How to reset If you delete the whole folder:
<your home>:Library:Application Support:StockXloader:
StockXloader will automatically recreate it and any necessary files in that folder
the next time StockXloader starts. This will also reset the Last Dates of down-
loads according to a choice of 1 day, week, month, year, 5 years, 10 years. If you
delete an individual file (such as the Notes file, or a ticker list), it will be recre-
ated as a new fresh file the next time you run StockXloader.

How to get a new ticker list template If you delete or rename a ticker list, StockXloader will create a new fresh ticker
list template when you choose Tools > Yahoo Tickers (EU), Yahoo Tickers (US), Yahoo Tickers (A)
or Yahoo Tickers (X), or when you restart StockXloader.

Ticker categorization StockXloader can automatically categorize most tickers into either stocks, mutual
funds, or indexes. The method to do that is based on the ticker format: Indexes
usually start with the character '^'; US mutual funds are exactly 5 characters
long of which the last is an 'X'; stocks are expected to be all other tickers.

Version 3.1.5 of StockXloader introduced simple means to explicitly specify the
category of each ticker. Tools > Ticker-list Guide shows examples and rules. This way
of explicitly specifying the category is now the preferred method, since it is both
general and robust—it enables you to specify also other categories, such as
options and futures, for which Yahoo has no unambiguous syntax. ProTA is
informed about the category by inserting a special character in the Universal
Text Importer's type column.
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5 NOTES ON YAHOO TICKERS

Translate tickers Most Yahoo tickers for non-US exchanges have a suffix indicating the stock
exchange, such as 'ST' for Stockholm. 

StockXloader can automatically strip this suffix if you tick Translate Yahoo tickers.
Example: 'ERIC-B.ST' will then translate into 'ERIC-B'. If you only deal with
tickers from one stock exchange (besides looking at world indexes), this may
make the tickers more familiar and easy to read, but if you work with several
stock exchanges, it is safer to keep the suffix.

Finding the ticker symbol To find the right ticker symbol for a certain security (share/stock, fund, index,
future, option) choose Tools > Yahoo Web Locations > Ticker Symbol Lookup (or the shortcut
equivalent Cmd-9), and then search for the security you are interested in. Beware
though, that not all tickers carry historical data—as of this date, most futures,
options, currencies and metals only have data for the current day. A recent
exception, however, is EURUSD=X, which, as of this date, actually has historical
data, despite it's not seen on their web page!

2-digit year interpretation Historical quotes from Yahoo may use either 4-digits or only 2 digits for the year,
whereas current day quotes always use 4 digits (but in a different format). Stock-
Xloader converts all dates into the form 5-Oct-2004. This date format is inde-
pendent of the one you choose in ProTA! Any 2-digit year higher than 27 is
interpreted to be 19xx. The new scheme will also accept 4-digit years, so as to
be prepared for such a change at Yahoo.

Close vs adjusted close The term Adjusted Close means that the Close quote has been multiplied by a
value as a result of splits and/or dividends. All Close quotes that StockXloader
imports to ProTA are the real Close quotes rather than any form of Adjusted
Close.

Although files for historical quotes from Yahoo do contain a column named
Adjusted Close, the majority of tickers for non-US markets have not been
adjusted at all, despite the claim and despite splits really have been performed.
And for tickers that actually have been adjusted, only the close is adjusted,
which means that the open/high/low quotes remain untouched, which is totally
unacceptable when charting these quotes! In contrast, when ProTA adjusts for
splits, all quotes for the day are adjusted, i.e open/high/low/close.

To avoid the risk of getting an inconsistent database of mixed Close/Adjusted
Close, depending on when you download, StockXloader only uses the real
Close, leaving any necessary database adjustments to be made in ProTA under
your full control. This will also ensure that when you perform such a split/price
adjustment, ProTA will set the appropriate note that specifies for which dates the
adjustment was executed.
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6 PROTA SETTINGS, CLASSIC VS OS X

6.1 Classic vs OS X

StockXloader works with both the Classic version of ProTA and the OS X version
(ProTA 3.x), but we assume that users now only use the OS X version of ProTA.
If you have not migrated from Classic ProTA to OS X ProTA, you can go directly
to Section 6.2.

If you have been using the Classic version of ProTA together with StockXloader,
and have migrated to the OS X version of ProTA, you probably have two Settings
Files called Min Standard and Min Standard1 (in ProTA, see Tools > Universal Text Importer,
click Settings Database). You can now safely delete those settings if you want, and
also delete any “bogus” ticker names Min Standard and Min Standard1 in your data-
base.

The rest of this chapter assumes that you are using ProTA version 3.0 or later, i.e
an OS X version of ProTA, which may either be a regular or a Gold version.

6.2 Settings for the Import Format

StockXloader can automatically tell ProTA (version 3.0 or later) which columns
contain which fields, and what the delimiter is, and what the number format is,
and ensure correct interpretation of dates. In addition, it specifies a Settings file
named StockXloader. The purpose is that it provides you with a method to
automatically associate a ticker mapping file, and a few other settings that
StockXloader itself does not control.

Figure 1 shows what StockXloader automatically controls, and what you can
choose to control. The latter items, encircled by green, can automatically be set
if you specify them in a Settings file named StockXloader, which automatically
will be loaded each time you import from StockXloader. 

A common and very useful feature is the Map Tickers: by defining a mapping file,
e.g called Yahoo, you can automatically have “awkward” Yahoo tickers mapped
to names you are more comfortable with, or you can separate ticker names from
different markets that happen to be identical. Ones you have defined this, each
time you import from StockXloader, all you have to do is to click the button Start
Import!

Figure 1 This is the import window that is shown each time you import from StockXloader. 
StockXloader automatically sets all items encircled by red, whereas the items encircled by green 
are items you control, and if you make a settings file called StockXloader, you can have those 
items set automatically each time you import from StockXloader.

You control this (green) StockXloader controls this automatically (red)
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Create a Settings File You create and edit the Settings File from within ProTA. Choose Tools > Universal Text
Importer, click Settings Database. Figure 2 shows what to do.

Next time you import from StockXloader, your settings will be loaded automati-
cally together with those that StockXloader controls. The import window that is
shown each time you import from StockXloader (Figure 1) will say that the
Settings File is called Custom; that is simply because it starts with your settings
StockXloader, and then control statements “modifies it” by setting the items encir-
cled by red in Figure 1.

Figure 2 This is the Settings Database in ProTA. Create a Settings File called StockXloader, 
and make your settings as desired. Ignore items outside the green line (Parsing, Dates & Num-
bers) since StockXloader controls those.

Create this Settings File. Make the settings as you desire.
Create a Mapping if you wish.Must be named StockXloader.

BragIt, c/o Harald E Brandt
Haeffnersvägen 18
SE-129 38 Hägersten
SWEDEN

WWW: http://invest.bragit.com
E-mail: inf@invest.bragit.com

Org. number: 540425-0192
VAT number: SE540425019201
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